Spamming Eviscerate since 2004

Stupid COmputer

my damn laptop is dying on me
I got ONE fps in a raid today, i haven’t seen FPS lower than 18 in YEARS
WTF IS THIS!!!

Advertisements

8 responses

  1. Are you getting the patch in the back ground?

    Do you use Cable for your internet connection?

    Did you check your router and connections?

    All pretty basic stuff but tonight we also had two of our healers having similar issues both of whom are using almost new and high end gaming machines. In the end we discovered it was an issue with Comcast their internet provider.

    Hope it fixes itself soon for you and in a less expensive way than a new computer.

    January 5, 2010 at 4:30 am

  2. i didn’t check my router thanks for the tip gonna tweak around and see if it helps

    ty fellow rogue 😀

    January 5, 2010 at 5:18 am

  3. And yet…

    …you were still doing better dps than a couple of the others… /sigh

    January 5, 2010 at 1:54 pm

  4. that’s because i’m amazing

    January 5, 2010 at 5:21 pm

  5. I DPS’d ONE PARTIAL BOSS FIGHT AND WAS #3.

    #3.

    Fuck, my sister-who is primary tank, and hates DPS-OUT DPS’D ONE OF OUR DPS MAINS.

    WHYYYYY.

    /coughs

    January 5, 2010 at 7:51 pm

  6. this is why i have no alts….haha

    January 5, 2010 at 8:58 pm

  7. Kotakh

    You were especially good on our first attemp on Jaraxxus 🙂

    January 7, 2010 at 3:48 pm

    • shut up kotex

      January 7, 2010 at 9:26 pm

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s